Fork me on GitHub

Installing HST Content Version Utils

Add Dependencies

Make sure you have the forge Maven2 repository reference and dependency definition in the root pom.xml of your project.

    <repositories>

      <!-- SNIP -->

      <repository>
        <id>hippo-maven2-forge</id>
        <name>Hippo Maven 2 Forge repository</name>
        <url>http://maven.onehippo.com/maven2-forge/</url>
        <snapshots />
      </repository>

      <!-- SNIP -->

    </repositories>

    <!-- SNIP -->

    <dependencyManagement>

      <!-- SNIP -->

      <dependencies>

        <!-- SNIP -->

        <!-- NOTE: You should set a property named 'forge.hst-versionutil.version' to a version of this plugin! -->

        <dependency>
          <groupId>org.onehippo.forge.hst-versionutil</groupId>
          <artifactId>hst-versionutil</artifactId>
          <version>${forge.hst-versionutil.version}</version>
        </dependency>

        <!-- SNIP -->

      </dependencies>

      <!-- SNIP -->

    </dependencyManagement>
    

And add the following dependency reference into your Hippo SITE Web Application module subproject.

    <dependencies>

      <!-- SNIP -->

      <dependency>
        <groupId>org.onehippo.forge.hst-versionutil</groupId>
        <artifactId>hst-versionutil</artifactId>
      </dependency>

      <!-- SNIP -->

    </dependencies>
    

Now, you're ready to use the module!